Skip to content

DHCP, Nat et VPN sur Cisco

Schema

Configuration de base et DHCP :

  1. Faire le plan d'adressage IP
  2. Configurer les paramètres IP sur les postes
  3. Configurer les paramètres IP sur les routeurs
  4. Mettre en place le routage statique sur R1 et R2
  5. Vérifier que tout fonctionne et enregistrer un fichier fonctionnel (pour pouvoir le reprendre en cas de problème).
  6. Centraliser le DHCP sur R3 et faire le relais DHCP sur les autres routeurs.
  7. Déconfigurer sur R1 et sur R2 le DHCP
  8. Configurer sur R1 et sur R2 le DHCP, puis passer les paramètres IP des stations en dynamique.
  9. Vérifier que les clients reçoivent les adresses IP dans les bons réseaux IP.

DHCP

Dans la configuration de l'interface qui est connecté au serveur :

Quand un serveur DHCP et un client ne se trouvent pas sur le même segment et sont séparés par un routeur, la commande ip helper-address permet de relayer les requêtes de broadcast.

ip helper-address «adresse DHCP»

pour relayer les requêtes de broadcast pour ces services UDP clés.

Il peut y avoir plusieurs helper-address si plusieurs serveurs.

ip dhcp pool «nom»
network «adresse réseau» «masque»
default-router «adresse de la passerelle»
dns-server «adresse serveur DNS»
domain-name «nom de domaine»
netbios-name-server «adresse serveur DNS»
lease «jours» «heures» «minutes»
exit
ip dhcp excluded-address «adresse exclue 1» «adresse exclue 2»

VPN PPTP

  1. Configurer un tunnel VPN GRE entre R1 et R2

  2. Configurez un serveur VPN PPTP sur R3

Configuration d'un Tunnel

Sur le routeur A :

interface tunnel 0
ip address 192.168.0.1 255.255.255.0
no shut
tunnel source serial 0/0
tunnel destination 1.2.3.2
tunnel mode gre ip

Sur le routeur B :

interface tunnel 0
ip address 192.168.0.2 255.255.255.0
no shut
tunnel source serial 0/0
tunnel destination 1.2.3.1
tunnel mode gre ip

Puis configurer le routage statique passant par le VPN.

Configuration d'un serveur PPTP (VPDN)

Sur le routeur :

vpdn enable
vpdn-group greta
accept dialin
protocol pptp
virtual-template 1
exit
ip local pool greta 10.0.0.1 10.0.0.100
interface virtual-Template 1
ip unnumbered serial 0/0
peer default ip address pool greta
ppp encrypt mppe auto required
ppp authentication ms-chap-v2 ms-chap
exit
username greta secret motdepasse

NAT :

  1. Masquez les adresses privées du LAN pour n'utiliser que les adresses publiques.

  2. Faites en sorte que les serveurs Web soient accessibles de l'extérieur.

  3. Une nouvelle adresse publique a été achetée pour le serveur, faites le Nat statique en remplacement de l'étape 2.

NAT statique

interface f 0/0
ip nat inside
interface s 0/0
ip nat outside
ip nat inside source static <adresse-interne> <adresse-externe>

Redirection de ports

interface f 0/0
ip nat inside
interface s 0/0
ip nat outside
ip nat inside source static tcp <adr-interne> <port> <adr-externe> <port> extendable
ip nat inside source static udp <adr-interne> <port> <adr-externe> <port> extendable

Masquage d'adresse (surcharge) :

ip nat pool <nom-du-pool> <ip-publique-début> <ip-publique-fin> netmask 255.255.255.0

Liste des adresses éligibles au masquage d'adresses :

access-list <n°> permit <adresse-réseau> <masque-générique>

Association de la liste d'adresses globale avec les adresses internes autorisées

ip nat inside source list <n°> pool <nom-du-pool> overload

Définition des interfaces du routeur Intranet/Internet

interface fa 0/0
ip nat inside
interface serial 0/0
ip nat outside