Skip to content

VPN PPTP sur les routeur Cisco

Cette documentation a été écrite il y a bien longtemps et n'est plus mise à jour. Comprenez que les informations que vous y trouverez peuvent avoir changé de manière conséquente !

I- Introduction :

Nous allons voir deux configurations possibles :

  • Le mode tunnel VPN, permet de chiffrer systématiquement toutes les informations qui sont transportées. C'est un cas classique quand on a deux sites d'une entreprise à relier à distance.
  • Le mode transport permet de fournir un accès VPN à divers clients distants (par exemple les commerciaux en déplacement quotidien).

Il existe de nombreux protocoles permettant de fournir le VPN.

Les protocoles présentés ici sont :

  • Un VPN de type PPTP
  • Une encapsulation Gre / IP pour le tunnel
  • Une authentification Chap pour le transport
  • Un chiffrement MPPE pour le mode transport

II- Mode tunnel :

                     A                                B

                IP publique :                    IP publique :
                1.2.3.1                          1.2.3.2
                IP du tunnel :                   IP du tunnel :
                192.168.0.1                      192.168.0.2
                                Vpn PPTP Gre
                      |<----------------------------->|
                      |                               |
+--------+            |           .~.~.~.             |           +--------+
|  Lan 1 |------[Routeur A]------{Internet}------[Routeur B]------|  Lan 2 |
+--------+                        ~.~.~.~                         +--------+
192.168.10.0/24                                                   192.168.20.0/24

Sur le routeur A :

(config)# interface tunnel 0
(config-if)# ip address 192.168.0.1 255.255.255.0
(config-if)# no shut
(config-if)# tunnel source serial 0/0
(config-if)# tunnel destination 1.2.3.2
(config-if)# tunnel mode gre ip

Sur le routeur B :

(config)# interface tunnel 0
(config-if)# ip address 192.168.0.2 255.255.255.0
(config-if)# no shut
(config-if)# tunnel source serial 0/0
(config-if)# tunnel destination 1.2.3.1
(config-if)# tunnel mode gre ip

Puis configurer le routage :

  • soit statique :

Routeur A :

(config)# ip route 192.168.20.0 255.255.255.0 192.168.0.2

Routeur B :

(config)# ip route 192.168.10.0 255.255.255.0 192.168.0.1
  • soit dynamique :

Routeur A :

(config)# router rip
(config-router)# network 192.168.10.0
(config-router)# network 192.168.0.0
(config-router)# passive interface fa 0/0

Routeur B :

(config)# router rip
(config-router)# network 192.168.20.0
(config-router)# network 192.168.0.0
(config-router)# passive interface fa 0/0

III- Mode transport :

                              Tunnel PPTP GRE
                     |<------------------------------>|
                     |                                |
                     |                                |
                     |                         /-- Client 1
+--------+           |            .~.~.~.     /
|  Lan 1 |------[Routeur A]------{Internet}------- Client 2
+--------+                        ~.~.~.~     \
192.168.10.0/24                                \-- Client 3

Sur le routeur :

(config)# vpdn enable
(config)# vpdn-group greta
(config-vpdn)# accept dialin
(config-vpdn-acc-in)# protocol pptp
(config-vpdn-acc-in)# virtual-template 1
(config-vpdn-acc-in)# exit
(config)# ip local pool greta 10.0.0.1 10.0.0.100
(config)# interface virtual-Template 1
(config-if)# ip unnumbered serial 0/0
(config-if)# peer default ip address pool greta
(config-if)# ppp encrypt mppe auto required
(config-if)# ppp authentication ms-chap-v2 ms-chap
(config)# exit
(config)# username greta secret motdepasse

Sur le client :

Créer une connexion à un VPN de type PPTP, MS-Chap-v2 avec chiffrement MPPE.

L'adresse est celle de l'interface publique du routeur.